寂寞的数

试题描述

   道德经曰:一生二,二生三,三生万物。   对于任意正整数n,我们定义d(n)的值为为n加上组成n的各个数字的和。例如,d(23)=23+2+3=28, d(1481)=1481+1+4+8+1=1495。   因此,给定了任意一个n作为起点,你可以构造如下一个递增序列:n,d(n),d(d(n)),d(d(d(n)))....例如,从33开始的递增序列为:   33, 39, 51, 57, 69, 84, 96, 111, 114, 120, 123, 129, 141, ...   我们把n叫做d(n)的生成元,在上面的数列中,33是39的生成元,39是51的生成元,等等。有一些数字甚至可以有两个生成元,比如101,可以由91和100生成。但也有一些数字没有任何生成元,如42。我们把这样的数字称为寂寞的数字。

输入

   一行,一个正整数n。

输出

   按照升序输出小于n的所有寂寞的数字,每行一个。

输入示例

   40

输出示例

   1
   3
   5
   7
   9
   20
   31

数据规模和约定

   n<=10000

参考代码(非最佳解法)

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int dn(int n)
{
	int nn=n;
	int count=0;
	do
	{
		count+=(nn%10);
	}while(nn/=10);
	return count+n;
}

int main()
{
	int N,temp;
	int a[10000]={0};
	scanf("%d",&N);
	for(int i=1;i<N;i++)
	{
		temp=i;
		do
		{
			temp=dn(temp);
			a[temp]=1;
		}while(temp<N);
	}
	for(int i=1;i<N;i++)
		if(a[i]==0) printf("%d\n",i);
	return 0;
} Code language: PHP (php)

有更好的方式您可以留言哦。

 如未特殊声明,文章均为原创。
 本文标题:寂寞的数
 本文链接:https://manwish.cn/article/%e5%af%82%e5%af%9e%e7%9a%84%e6%95%b0.html

留下评论